DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Electrical


Notices

Electrical 2nd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 09-22-2011, 10:31 AM
Alex Redrider Alex Redrider is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2011
Location: Hollywood
Posts: 7
Gender: Male
Vehicle: 2011 Ram Sport
Trim Level: Sport
Color: Red
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Alex Redrider is on a distinguished road
Default Map Lights not working HELP!

Hey guys, just bought some LED's for the twin Map lights on my 2011 Sport. They never turned on and there was a nasty smell coming from the LED diode. Figured that I burned it out so I put the original bulb in and it does not work. Did the same to the other light and same happened.
What I don't get is that EVERY other light still works on the truck. The one fuse under the hood still looks good too. Any help?????

Last edited by Alex Redrider; 09-22-2011 at 10:33 AM. Reason: Wrong Location
Reply With Quote
Sponsored links
  #2  
Old 09-22-2011, 01:04 PM
camoman214 camoman214 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2011
Posts: 217
Gender: Male
Vehicle: None right now
Rep Power: 0
Rep:11
camoman214 is on a distinguished road
Default

Check the IOD fuse. My IOD fuse was blown and my map lights didn't work. Replaced the IOD and now they operate as they should.
__________________

Reply With Quote
  #3  
Old 09-23-2011, 08:54 AM
Alex Redrider Alex Redrider is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2011
Location: Hollywood
Posts: 7
Gender: Male
Vehicle: 2011 Ram Sport
Trim Level: Sport
Color: Red
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Alex Redrider is on a distinguished road
Default

hey, whatever works. I'll give it a shot this afternoon. Thanks
Reply With Quote
  #4  
Old 09-23-2011, 12:40 PM
camoman214 camoman214 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2011
Posts: 217
Gender: Male
Vehicle: None right now
Rep Power: 0
Rep:11
camoman214 is on a distinguished road
Default

I believe the IOD circuit carries the power mirrors and radio current as well, so check to see if those are operational.
__________________

Reply With Quote
Reply

Bookmarks

Tags
interior, led, map light

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake lights not working gkconcepts Newbie Checkin! 11 07-22-2012 02:26 PM
Fog lights not working on 2001 Dodge ram stmabe Electrical 8 09-17-2011 01:15 AM
tail lights not working dasr12006 Electrical 5 06-15-2011 04:16 PM
Reverse Lights Not Working dschluet 5.2L V8 Specific Topics 4 02-27-2011 01:07 PM
Fog Lights not working?? Aries 2010 Dodge Ram Forum 7 11-20-2010 02:20 PM


Advertisement






All times are GMT -4. The time now is 09:36 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum