DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Electrical


Notices

Electrical 2nd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 08-22-2014, 01:32 PM
ROKNK5 ROKNK5 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2009
Posts: 2
Gender: Male
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
ROKNK5 is on a distinguished road
Default 2000 Ram - Lost FM Stations

2000 Ram, 135K miles, factory radio (CD & cassette tape). I've lost all FM stations, all I get is static. Oddly, I can pick up AM stations. Antenna on exterior of truck is tight. Any ideas?
Thanks,
DC
Reply With Quote
Sponsored links
  #2  
Old 08-22-2014, 08:47 PM
logang logang is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2014
Location: New Mexico
Posts: 20
Gender: Male
Vehicle: 2003 Dodge Ram 1500
Trim Level: SLT
Color: Dark Garnet Red Pearlcoat
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:10
logang is on a distinguished road
Default

Try checking the antenna cable going into the rear of the radio. Follow the antenna cable as best as you can to where it joins the antenna behind the wheel well cover under the antenna, it may have become disconnected somehow.
Reply With Quote
  #3  
Old 08-24-2014, 12:09 AM
Lazarus Truck Lazarus Truck is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2013
Location: MI
Posts: 743
Gender: Male
Vehicle: 1997 Dodge Ram
Trim Level: SLT
Color: Black
Engine: 1994-1997 360ci (5.9L) Magnum V8 230hp
Rep Power: 1
Rep:190
Lazarus Truck has a spectacular aura aboutLazarus Truck has a spectacular aura about
Default

I just had my right fender off for some work. There was CRAZY corrosion where the antenna cable went into the antenna base. Couldn't get them apart. If you can find a test antenna and cable, there is a splice connector under the passenger side of the dash, right above your feet for the antenna. Plug in a known good antenna, and that should help locate your problem.
__________________
The difference between genius and stupidity, is that genius has it's limits. A. Einstein
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 05:22 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum