DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.2L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 08-28-2013, 09:46 AM
1999ram318 1999ram318 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: Wisconsin
Age: 18
Posts: 3
Gender: Male
Vehicle: 1999 Dodge Ram
Color: Forrest Green
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 0
Rep:10
1999ram318 is on a distinguished road
Unhappy Overdrive turns off while driving?

Hi everybody. I just bought my ram about a mobth ago. Last week i just got it out of the shop after having the rear end rebuilt. Yesterday i was driving and the o/d off light came on and the engined reved up real high. I cant afford to have the transmission rebuilt. Would a transmission flush with a new filter fix it? Or could it be a sensor? Anybody else have this problem?
Reply With Quote
Sponsored links
  #2  
Old 09-06-2013, 12:33 PM
ramvan2500's Avatar
ramvan2500 ramvan2500 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2011
Location: Florida USA
Posts: 1,803
Gender: Male
Vehicle: 1995 Dodge Ram B2500 Van
Trim Level: SLT - 2500
Color: Deep Molten Pearl Coat, Silver, Grey
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 4
Rep:127
ramvan2500 will become famous soon enoughramvan2500 will become famous soon enough
Default

Quote:
Originally Posted by 1999ram318 View Post
Hi everybody. I just bought my ram about a mobth ago. Last week i just got it out of the shop after having the rear end rebuilt. Yesterday i was driving and the o/d off light came on and the engined reved up real high. I cant afford to have the transmission rebuilt. Would a transmission flush with a new filter fix it? Or could it be a sensor? Anybody else have this problem?
well it sounds like a electronic problem, the od light goes on (means od off) when the transmission gets too hot. most times the transmission doesn't really get hot enough to disable OD, so I would check the sensors the temp sensor which is shared with the governor pressure sensor i think... but fluid change isn't going to do anything. just be sure to adjust the bands when you remove the pan. the front band can be changed without pan removal but the rear band is an internal adjustment.
Reply With Quote
Reply

Bookmarks

Tags
overdrive, transmission

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 11:04 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum