DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Mod Zone - Custom Dodge Ram Mods - Dodge Ram Performance > Custom Dodge Ram Interior and Exterior Lighting


Notices

Custom Dodge Ram Interior and Exterior Lighting HID - HALO - LED LIGHTING - UNDERBODY LIGHTING - TINTED/SMOKED/PAINTED TAILS - ETC.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 08-15-2014, 02:24 AM
dmac101 dmac101 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Nov 2011
Posts: 353
Gender: Male
Vehicle: 2012 dodge ram
Trim Level: laramie
Color: black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:39
dmac101 is on a distinguished road
Default think im going to give up on hids

so heres my story, i ordered mid range 50 dollar hid kit, 35w, to instal in my fogs, have read that fogs are straight forward plug and play, but i ordered error code eliminators off ebay just incase, (have used them before with success)

i installed the hids in my fogs without the eliminators first, turned switch on they worked, started truck, one worked one was very dim. and both flikered a little not hyper flashing just a little flicker.

so i unplugged them and installed the error code/anti flickers, the dim light was now bright, both were bright, i finally had properly working hids, (so i thought).

i waited till it got darker to check them out, of course the passenger one is flikering a little now, drive is perfect, both nice and bright, just that little flicker in the passenger

so what do i need here? im about ready to give up on hids, love the look but nothing but issues on this truck with them
Reply With Quote
Sponsored links
  #2  
Old 10-06-2014, 06:19 PM
soliphant85's Avatar
soliphant85 soliphant85 is offline
Dodge Ram Forum Newcomer
 
Join Date: Jun 2014
Location: Alberta
Age: 29
Posts: 18
Gender: Male
Vehicle: 2010 Ram 1500
Trim Level: TRX4
Color: Black
Engine: 2009-2012 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
soliphant85 is on a distinguished road
Default

as i just posted on another HID post after market HID's for newer dodges have to be CANBUS compatible otherwise the computer thinks there is a problem, hence the flickering.
__________________
Scott;
2010 Ram 1500 TRX4 w/ too many mods for this signature block to handle!
Reply With Quote
  #3  
Old 10-06-2014, 06:32 PM
Bordin's Avatar
Bordin Bordin is offline
Dodge Ram Forum Senior Member!
 
Join Date: May 2011
Location: Northern Ontario, Canada
Age: 24
Posts: 1,384
Gender: Male
Vehicle: 2011 Ram Sport Ram Hood
Trim Level: Sport
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 5
Rep:516
Bordin is a glorious beacon of lightBordin is a glorious beacon of lightBordin is a glorious beacon of lightBordin is a glorious beacon of lightBordin is a glorious beacon of lightBordin is a glorious beacon of light
Default

I run HID in my low/highs. I have the quad lamps so separate bulbs each.

I run a relay harness each (2 harnesses in total).I only run 1 Error Code Eliminator per harness, I think it's my feed/switch source, than the other side of the error code goes to my relay.
Without that error code, lights turn on when the truck is off, but once I start the truck and turn the lights on, starts flickering and don't even work half the time.

I have been running this setup for over 2 years without any issues. Only thing I have done was a retrofit on my lights but just installed new bulbs and used all my old harnesses. Worked fine.

Check out www . ddmtuning .com/ (no spaces)

This is where I order all my lights from, well HIDs.

NOTE: I ran HIDs in my fogs, no error code eliminators and everything worked 100%. Than I retrofitted them to LED so they left. Not sure if 2012 they changed the fogs to the canbus system??

__________________

Last edited by Bordin; 10-06-2014 at 06:37 PM.
Reply With Quote
  #4  
Old 10-06-2014, 06:44 PM
Firemedic10584 Firemedic10584 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Nov 2013
Location: Central FL
Posts: 785
Gender: Male
Vehicle: 2013 Ram 1500 Sport
Trim Level: Sport
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 2
Rep:120
Firemedic10584 will become famous soon enoughFiremedic10584 will become famous soon enough
Default

Yup, u need CANBUS ballasts. I have had mine in now for 10-11 months with no issues. I am just running the CANBUS ballasts and bulbs, no other harnesses or anything. I have no error messages and (knock on wood) haven't had a bulb not fire yet. 2013 sport with projectors is what I have.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 07:11 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum