DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 2ND Generation Dodge Ram 1994 to 2001 Dodge Ram Trucks > Powertrain > 5.9L V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #11  
Old 01-16-2013, 05:17 AM
MDReptile MDReptile is offline
Dodge Ram Forum Junior Member
 
Join Date: Jun 2012
Age: 26
Posts: 38
Gender: Male
Vehicle: 98 1500 5.9L QuadCab Sport RWD
Rep Power: 0
Rep:10
MDReptile is on a distinguished road
Default

I think its still got oil left, but its getting pretty black from being late for a change. Might be lower since i last checked. I'll do the oil change first here next week, then if the light remains at stops, the send unit.
Reply With Quote
Sponsored links
  #12  
Old 01-16-2013, 09:12 AM
elinmon1976's Avatar
elinmon1976 elinmon1976 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Oct 2011
Location: Salem,VA
Age: 38
Posts: 237
Gender: Male
Vehicle: 2004 Ram 1500 quadcab 2wd
Trim Level: SLT
Color: tan
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:65
elinmon1976 will become famous soon enough
Default

My 98 5.2 did this and I was losing oil due to a plenum leak as well. Was going through about 3 quarts every othe week or so.
__________________
2004 Quad cab 2wd 4.7L

1998 Ram Reg Cab, 5.2 auto 2x4
Flowmasters to make her rumble...LOL
Reply With Quote
  #13  
Old 01-16-2013, 12:04 PM
DOZER's Avatar
DOZER DOZER is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2011
Location: Beacon, NY
Age: 49
Posts: 709
Gender: Male
Vehicle: 2006 Ram 2500 Quad cab 4x4
Trim Level: ST
Color: Atlantic Blue
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 4
Rep:140
DOZER will become famous soon enoughDOZER will become famous soon enough
Send a message via Yahoo to DOZER Send a message via Skype™ to DOZER
Default

Quote:
Originally Posted by elinmon1976 View Post
My 98 5.2 did this and I was losing oil due to a plenum leak as well. Was going through about 3 quarts every othe week or so.
WOW 3 quarts every other week. Mine was only loosing a quart a month.
__________________
'06 2500 ST 4x4 Quad cab, Vararam CAI, Bed/Hood stripes, Vent visors, Bully tailgate lock, Moto Metal 909 18x9, Nitto Terra Grapplers 295/70/18 HBS 2" level, Bilstein 5100's, Bushwhacker flares, 5000K HID's, Diablo Trinity 87 tune, LineX, Bakflip F1.
Reply With Quote
  #14  
Old 01-16-2013, 02:47 PM
MDReptile MDReptile is offline
Dodge Ram Forum Junior Member
 
Join Date: Jun 2012
Age: 26
Posts: 38
Gender: Male
Vehicle: 98 1500 5.9L QuadCab Sport RWD
Rep Power: 0
Rep:10
MDReptile is on a distinguished road
Default

Umm yeah I'm pretty sure that's not happening, but your making me nervous lol, I will double check the oil level when I go out later. I think its really an electronic thing, and at this point I really hope so! Sounds like the other possibilities are much more severe. What's a plenum leak mean? Does that mean like burning off oil?

Edit: ok read up in that, sure hope I'm not experiencing this, checked the oil, both running and off, does seem low when off, but perhaps even too much while its running... I'll try to get under the top off the engine to check the possibility of plenum leaking going on... Gulp...

Last edited by MDReptile; 01-16-2013 at 06:01 PM.
Reply With Quote
  #15  
Old 01-17-2013, 11:06 PM
Howells's Avatar
Howells Howells is offline
Dodge Ram Forum Junior Member
 
Join Date: May 2011
Location: Kitchener ont.
Age: 31
Posts: 49
Gender: Male
Vehicle: 1999 dodge ram sport 5.9l
Trim Level: sport 4x4
Color: Black
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:19
Howells is on a distinguished road
Default

If your overdue for an oils change you might be down abit in oil,this is normal. Change out the sensor that's the most common problem. For the needle dropping down and your light coming on. I have also seen these sensors leak abit also causing the same problem.
Reply With Quote
  #16  
Old 01-18-2013, 10:04 AM
MDReptile MDReptile is offline
Dodge Ram Forum Junior Member
 
Join Date: Jun 2012
Age: 26
Posts: 38
Gender: Male
Vehicle: 98 1500 5.9L QuadCab Sport RWD
Rep Power: 0
Rep:10
MDReptile is on a distinguished road
Default

Well here either later today, or early next week I'll be doing the oil change finally, and possibly tranny fluid if I'm feeling ambitious. I'll take it for a spin and brake hard and turn tight, and if that light beeps at me I'm gonna turn around and get that sensor right away. I'll be sue to let you guys know how low it really turns out to be, and if i have to get that part put in or not.
Reply With Quote
  #17  
Old 01-18-2013, 10:10 AM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

If this is happening when you brake hard or turn sharply, my money says it's not a sensor issue. You probably have a sludge/pickup/pump issue.
Reply With Quote
  #18  
Old 01-19-2013, 01:29 AM
MDReptile MDReptile is offline
Dodge Ram Forum Junior Member
 
Join Date: Jun 2012
Age: 26
Posts: 38
Gender: Male
Vehicle: 98 1500 5.9L QuadCab Sport RWD
Rep Power: 0
Rep:10
MDReptile is on a distinguished road
Default

Oil change did the trick. Old oil must have been screwing with the sensor... Was low, probably to be expected this late to change. Thanks for all the help guys!

Edit: oh hey, obviously don't forget to change the filter, and if your oil is not getting old, it could be really low! Do check both of those first if you get this problem, now its running like a champ. I used castrol high mileage Dino oil if that matters at all.

Last edited by MDReptile; 01-19-2013 at 01:34 AM.
Reply With Quote
  #19  
Old 01-19-2013, 08:18 AM
RamTech's Avatar
RamTech RamTech is offline
Dodge Ram Forum Senior Member!

 
Join Date: Nov 2009
Location: Johnson City, TN
Age: 44
Posts: 12,120
Gender: Male
Vehicle: 2004 Dakota Club Cab 4X4
Trim Level: SXT
Color: Bright Silver
Engine: 2002-2008 226ci (3.7L) Magnum/PowerTech V6 215hp 235lb/ft
Rep Power: 14
Rep:1824
RamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant futureRamTech has a brilliant future
Default

Quote:
Originally Posted by MDReptile View Post
Oil change did the trick. Old oil must have been screwing with the sensor... Was low, probably to be expected this late to change. Thanks for all the help guys!

Edit: oh hey, obviously don't forget to change the filter, and if your oil is not getting old, it could be really low! Do check both of those first if you get this problem, now its running like a champ. I used castrol high mileage Dino oil if that matters at all.
If your oil was that low between changes, I'd bet you have a blown plenum pan gasket. Fix that and your consumption problem will go away.
Reply With Quote
  #20  
Old 01-20-2013, 05:58 PM
MDReptile MDReptile is offline
Dodge Ram Forum Junior Member
 
Join Date: Jun 2012
Age: 26
Posts: 38
Gender: Male
Vehicle: 98 1500 5.9L QuadCab Sport RWD
Rep Power: 0
Rep:10
MDReptile is on a distinguished road
Default

Hmm, possibly, and i never got around to checking that. I'll have to have a look - I should see a little puddle of oil in there under the plastic coverings right? I googled a bit about that but didn't find any pictures or anything. Edit: found this video,


Is that what you mean?

Last edited by MDReptile; 01-20-2013 at 06:07 PM.
Reply With Quote
Reply

Bookmarks

Tags
5.9l, hard brake, oil pressure, sport, stop

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 12:32 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum