DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Mod Zone - Custom Dodge Ram Mods - Dodge Ram Performance > Custom Dodge Ram Performance Mods - Engine - 5.9 Liter V8 > Exhaust


Notices

Exhaust 5.9L Exhaust Discussion


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 11-01-2012, 12:49 PM
momo1 momo1 is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2012
Location: Jeannette, Pa.
Age: 71
Posts: 2
Gender: Male
Vehicle: 2010 Dodge Ram 1500
Trim Level: Big Horn Crew Cab
Color: Gray
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
momo1 is on a distinguished road
Default Flowmaster Series 10

I have a 2010 1500 with the 5.9 Hemi, It has the factory duel exhaust 3" in 2 1/2 dual out . I installed a Flowmaster series 10 muffler and left the two resonators on. Now I have what sounds like an engine sputter at low speed, if I give it a little more gas it goes away for awhile until I give it gas again and it starts all over again. I took it to two different Dodge dealers and they couldn't find anything wrong with the engine, transmission or anything else for that matter. Any ideas?
Reply With Quote
Sponsored links
  #2  
Old 11-04-2012, 08:32 AM
Oldskoolram Oldskoolram is offline
Dodge Ram Forum Junior Member
 
Join Date: Oct 2012
Location: Pasadena,TX
Age: 39
Posts: 30
Gender: Male
Vehicle: 97 ram
Trim Level: RCSB sport
Color: Black
Engine: 1994-1997 360ci (5.9L) Magnum V8 230hp
Rep Power: 0
Rep:10
Oldskoolram is on a distinguished road
Default

Well I would venture to say it may be or have something to do with the muffler. Are you sure its an engine sputter or is it an exhaust gurgle since the series 10 is a single chamber muffler. My 97 rcsb has one of these and it does seem to have a slight gurgle and very lowthrottle but when you give it the cheeses it goes away. Its only a guess,but have you taken it back to the muffler shop that installed it to make sure there were no problems?
Reply With Quote
  #3  
Old 02-16-2013, 05:33 PM
damnkidd012 damnkidd012 is offline
Dodge Ram Forum Newcomer
 
Join Date: Sep 2012
Location: boston
Age: 20
Posts: 11
Gender: Male
Vehicle: 97 ram 2500
Trim Level: base
Color: green
Engine: 1994-1997 360ci (5.9L) Magnum V8 230hp
Rep Power: 0
Rep:10
damnkidd012 is on a distinguished road
Default

I think thats just the flows cuz i have 40s on my 5.9 and it does that whenever im just rolling
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 01:13 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum