DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 4TH Generation Dodge Ram 2009+ Dodge Ram Trucks > Powertrain > 4.7L (287 cu in) PowerTech V8 Specific Topics


Notices


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 01-30-2013, 05:35 PM
hulagrubman hulagrubman is offline
Dodge Ram Forum Newcomer
 
Join Date: Dec 2012
Location: union, wv
Age: 41
Posts: 1
Gender: Male
Vehicle: 2009 dodge ram slt
Trim Level: slt
Color: white
Engine: 2008-20?? 287ci (4.7L) PowerTech V8 310hp 330lb/ft
Rep Power: 0
Rep:10
hulagrubman is on a distinguished road
Default ESP, ABS, SERV4WD lights came on... HELP!

pulled into work today and these lights came on. left work and they went off then came back on as i pulled into drive. been reading on here some and sounds like maybe wheel sensor or ABS module. looked under truck and found small wire going to back of wheel assembly with a harness. is this the sensor? wires look fine on both sides of truck and harness was tight. is there anything i can check and if so where? i have the 5 year warranty that is up in 2014 (2009 model 1500 slt) and the dealership is an hour away so i thought i might check here first before calling them. the truck drives fine. i have been spraying it off pretty frequent due to salt from treated roads. thanks for looking-sean
Reply With Quote
Sponsored links
  #2  
Old 01-31-2013, 09:05 AM
Rocky Harbour Rocky Harbour is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2009
Location: Rocky Harbour, NL. Canada
Posts: 126
Gender: Male
Vehicle: 2010 Dodge 1500 Ram - Quad Cab
Trim Level: TRX 4 Off Road
Color: Brilliant Black Crystal Pearl / Light Greystone Pearl
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:26
Rocky Harbour is on a distinguished road
Default

I had the same thing happen to me. It was a wheel speed sensor. Unfortunately it will probably take a trip to the dealership for diagnosis.
Reply With Quote
  #3  
Old 04-10-2013, 02:22 PM
NewfoundlandRam's Avatar
NewfoundlandRam NewfoundlandRam is offline
Dodge Ram Forum Junior Member
 
Join Date: Feb 2013
Location: Newfoundland
Age: 22
Posts: 43
Gender: Male
Vehicle: 2009 Dodge Ram
Trim Level: Laramie
Color: Red
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
NewfoundlandRam is on a distinguished road
Default

I had the same problem, it was also the wheel speed sensor
__________________
09 Ram 1500 Laramie, 94 Ford mustang, 03 HD Heritage softail, 08 Outlander xt 800, 08 Summit x 800r
Reply With Quote
  #4  
Old 04-16-2013, 12:29 AM
Unfairkickazz93's Avatar
Unfairkickazz93 Unfairkickazz93 is offline
Dodge Ram Forum Member
 
Join Date: Dec 2011
Location: Fairbanks, AK/East Jordan, MI
Age: 21
Posts: 1,780
Gender: Male
Vehicle: 2012 Dodge Ram 1500 RCSB 4X4
Trim Level: Express
Color: Flame Red
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 3
Rep:173
Unfairkickazz93 has a spectacular aura aboutUnfairkickazz93 has a spectacular aura about
Default

Yeah, that happened on my 12. It was the wheel speed sensor.
__________________
MODS- QTP Exhaust Cutout, ARH Long-tube Headers, HornBlasters Train Horn, HemiFever Tuned, Linex bedliner, Painted mirrors and door handles, 14" magnaflow muffler, Cabin air filter, BakFlip G2 tonneau cover, Black 17" Sport Edition TK5 Wheels, K&N CAI, BT Catch can, 85mm Throttle body, Upper glovebox Mod, Recon Black Projector headlights, Retroshops- Tinted LED Tails including 3rd brake.
Reply With Quote
  #5  
Old 05-30-2013, 11:01 AM
NewfoundlandRam's Avatar
NewfoundlandRam NewfoundlandRam is offline
Dodge Ram Forum Junior Member
 
Join Date: Feb 2013
Location: Newfoundland
Age: 22
Posts: 43
Gender: Male
Vehicle: 2009 Dodge Ram
Trim Level: Laramie
Color: Red
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
NewfoundlandRam is on a distinguished road
Default

Same thing with my '09
__________________
09 Ram 1500 Laramie, 94 Ford mustang, 03 HD Heritage softail, 08 Outlander xt 800, 08 Summit x 800r
Reply With Quote
  #6  
Old 05-30-2013, 08:25 PM
ThisGuy93 ThisGuy93 is offline
Dodge Ram Forum Newcomer
 
Join Date: May 2013
Location: Thousand Jokes
Posts: 13
Gender: Male
Vehicle: 2009 ram 1500
Color: Silver
Rep Power: 0
Rep:10
ThisGuy93 is on a distinguished road
Default

atleast it wont hurt anything driving, but take it to the dealer!!!
Reply With Quote
  #7  
Old 06-01-2013, 08:53 AM
dodgeman1821's Avatar
dodgeman1821 dodgeman1821 is offline
Dodge Ram Forum Newcomer
 
Join Date: May 2013
Location: Murphysboro ill
Age: 55
Posts: 22
Gender: Male
Vehicle: 2010 dodge ram trx4
Trim Level: Trx4 standard cab
Color: deepwater blue over graphite
Engine: 2008-20?? 287ci (4.7L) PowerTech V8 310hp 330lb/ft
Rep Power: 0
Rep:10
dodgeman1821 is on a distinguished road
Default

it happened to my 2010 trx4 all the same lights came on, esp,abs service4x4 , ended up wheel sensor and the 4 wheel drive module . it was under warent, and the put new one on and new wheel sensor all fixed
Reply With Quote
  #8  
Old 06-04-2013, 02:16 PM
jcadle jcadle is offline
Dodge Ram Forum Newcomer
 
Join Date: Nov 2012
Location: Ohio
Posts: 2
Gender: Male
Vehicle: 2009 Dodge Ram 1500 4x4
Trim Level: Laramie
Color: black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
jcadle is on a distinguished road
Default

I had the same problem with my 09 laramie. turned out that it was the ABS module. i installed a new one but, still had to take it to the dealership to have the VIN coded in the new module. all the bad lights went out
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 04:47 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum