DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > Dodge Ram Special Edition Models > Dodge Ram Vans


Notices

Dodge Ram Vans For discussion of Dodge Ram Vans. Please use our existing technical areas for driveline discussion, etc.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 05-31-2012, 06:50 PM
mattb3500 mattb3500 is offline
Dodge Ram Forum Newcomer
 
Join Date: May 2012
Location: Nashville
Age: 30
Posts: 1
Gender: Male
Vehicle: 2000 Doge Ram Van 3500 5.9
Trim Level: Base
Color: White
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
mattb3500 is on a distinguished road
Unhappy PLEASE HELP, van needs to get me back to work!

I have a 2000 Dodge Ram Van 3500, ext cargo, ext height conversion van. It is powered by a 5.9 Magnum V8 with A518\46RE Auto trans and 4:11 rear. It has just turned over 180k miles. When I first bought this beast, I had Mr. Trans exchange trans fluid and filter, engine oil and filter, P.S.fluid, rear diff fluid, and clean and adjust rear brakes. Also had a new exhaust with high flow cat and flowmaster muffler. Personally, I have done: front brake pads, rotors turned, new bearings, plugs,cap,rotor, TB mod with JY part (still testing it out), 4 shocks, belt and pulleys, K & N filter, pcv valce, crankcase breather. This van runs and sounds great, better than that, actually, AMAZING....just one small intermittent issue....


On the way home(weeks ago), the engine spontaneously revved super high and the transmission "fell outta gear" ...when i pushed on the gas pedal, no increase in momentum, but increase heard in rpm. Pulled over and checked fluid, it was between the marks. (I have replaced fluid and filter 2x since ownership) I was able to limp home, during the last few miles the van drove problem free normally. This marked the beginning of an intermittent trans malfunction that was later explained to me as voltage signal lost to the gov. press. sol..

I had it towed to double ay, em, see ,ohh and they told me it was an internal trans problem. $2,150.00I later I have a rebuilt trans (and fancy new cooler) with the same intermittent problem. Took it back for more solenoids, clips,and harnesses, even got a new O2 sensor (downstream). Still acts up randomly. They took it to dealership to confirm their suspicion of the PCM, but dealer stated in B&W there was an internal transmission problem...possibly "in the drum" . Trans guys jumped a wire close to pcm connector harness to trans harness, no change. I have had it back there 5 times, the fifth was an entire week long.

I replaced the TPS with a another I bought with the junk yard throttle body. no change...I replaced the PCM harness with one from identical vehicle....no change.

What am/are I/we missing?


I don't know what else to do! Throwing parts is not practical when considering the price of a new PCM & Programming. (yes i tried the online computer exchange and the experience was pathetic and the REMAN part BOGUS)
I know there are other engine sensors in the same 5v PCM circuit as the gov press sol, but REPLACE THEM ALL?!?! Are there better ways to test each individual sensor?

Clearly I don't own a DRB scan tool, but how can I know for certain the PCM is at fault? (Mopar reman dated 2006)
Should I buy a new TPS? Or have a shop sweep both TPS and Alternator with an oscilloscope?
I am proficient with my Fluke true RMS multimeter, and I do have the service manuals and haynes manual.
Any suggestions are greatly appreciated!
Reply With Quote
Sponsored links
  #2  
Old 05-31-2012, 10:57 PM
ramvan2500's Avatar
ramvan2500 ramvan2500 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2011
Location: Florida USA
Posts: 1,870
Gender: Male
Vehicle: 1995 Dodge Ram B2500 Van
Trim Level: SLT - 2500
Color: Deep Molten Pearl Coat, Silver, Grey
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 4
Rep:127
ramvan2500 will become famous soon enoughramvan2500 will become famous soon enough
Default

Quote:
Originally Posted by mattb3500 View Post
I have a 2000 Dodge Ram Van 3500, ext cargo, ext height conversion van. It is powered by a 5.9 Magnum V8 with A518\46RE Auto trans and 4:11 rear. It has just turned over 180k miles. When I first bought this beast, I had Mr. Trans exchange trans fluid and filter, engine oil and filter, P.S.fluid, rear diff fluid, and clean and adjust rear brakes. Also had a new exhaust with high flow cat and flowmaster muffler. Personally, I have done: front brake pads, rotors turned, new bearings, plugs,cap,rotor, TB mod with JY part (still testing it out), 4 shocks, belt and pulleys, K & N filter, pcv valce, crankcase breather. This van runs and sounds great, better than that, actually, AMAZING....just one small intermittent issue....


On the way home(weeks ago), the engine spontaneously revved super high and the transmission "fell outta gear" ...when i pushed on the gas pedal, no increase in momentum, but increase heard in rpm. Pulled over and checked fluid, it was between the marks. (I have replaced fluid and filter 2x since ownership) I was able to limp home, during the last few miles the van drove problem free normally. This marked the beginning of an intermittent trans malfunction that was later explained to me as voltage signal lost to the gov. press. sol..

I had it towed to double ay, em, see ,ohh and they told me it was an internal trans problem. $2,150.00I later I have a rebuilt trans (and fancy new cooler) with the same intermittent problem. Took it back for more solenoids, clips,and harnesses, even got a new O2 sensor (downstream). Still acts up randomly. They took it to dealership to confirm their suspicion of the PCM, but dealer stated in B&W there was an internal transmission problem...possibly "in the drum" . Trans guys jumped a wire close to pcm connector harness to trans harness, no change. I have had it back there 5 times, the fifth was an entire week long.

I replaced the TPS with a another I bought with the junk yard throttle body. no change...I replaced the PCM harness with one from identical vehicle....no change.

What am/are I/we missing?


I don't know what else to do! Throwing parts is not practical when considering the price of a new PCM & Programming. (yes i tried the online computer exchange and the experience was pathetic and the REMAN part BOGUS)
I know there are other engine sensors in the same 5v PCM circuit as the gov press sol, but REPLACE THEM ALL?!?! Are there better ways to test each individual sensor?

Clearly I don't own a DRB scan tool, but how can I know for certain the PCM is at fault? (Mopar reman dated 2006)
Should I buy a new TPS? Or have a shop sweep both TPS and Alternator with an oscilloscope?
I am proficient with my Fluke true RMS multimeter, and I do have the service manuals and haynes manual.
Any suggestions are greatly appreciated!
The TPS isn't the issue, it probably is the torque converter or the ECM.
Reply With Quote
  #3  
Old 05-31-2012, 11:00 PM
ramvan2500's Avatar
ramvan2500 ramvan2500 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Apr 2011
Location: Florida USA
Posts: 1,870
Gender: Male
Vehicle: 1995 Dodge Ram B2500 Van
Trim Level: SLT - 2500
Color: Deep Molten Pearl Coat, Silver, Grey
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 4
Rep:127
ramvan2500 will become famous soon enoughramvan2500 will become famous soon enough
Default

Quote:
Originally Posted by mattb3500 View Post
I have a 2000 Dodge Ram Van 3500, ext cargo, ext height conversion van. It is powered by a 5.9 Magnum V8 with A518\46RE Auto trans and 4:11 rear. It has just turned over 180k miles. When I first bought this beast, I had Mr. Trans exchange trans fluid and filter, engine oil and filter, P.S.fluid, rear diff fluid, and clean and adjust rear brakes. Also had a new exhaust with high flow cat and flowmaster muffler. Personally, I have done: front brake pads, rotors turned, new bearings, plugs,cap,rotor, TB mod with JY part (still testing it out), 4 shocks, belt and pulleys, K & N filter, pcv valce, crankcase breather. This van runs and sounds great, better than that, actually, AMAZING....just one small intermittent issue....


On the way home(weeks ago), the engine spontaneously revved super high and the transmission "fell outta gear" ...when i pushed on the gas pedal, no increase in momentum, but increase heard in rpm. Pulled over and checked fluid, it was between the marks. (I have replaced fluid and filter 2x since ownership) I was able to limp home, during the last few miles the van drove problem free normally. This marked the beginning of an intermittent trans malfunction that was later explained to me as voltage signal lost to the gov. press. sol..

I had it towed to double ay, em, see ,ohh and they told me it was an internal trans problem. $2,150.00I later I have a rebuilt trans (and fancy new cooler) with the same intermittent problem. Took it back for more solenoids, clips,and harnesses, even got a new O2 sensor (downstream). Still acts up randomly. They took it to dealership to confirm their suspicion of the PCM, but dealer stated in B&W there was an internal transmission problem...possibly "in the drum" . Trans guys jumped a wire close to pcm connector harness to trans harness, no change. I have had it back there 5 times, the fifth was an entire week long.

I replaced the TPS with a another I bought with the junk yard throttle body. no change...I replaced the PCM harness with one from identical vehicle....no change.

What am/are I/we missing?


I don't know what else to do! Throwing parts is not practical when considering the price of a new PCM & Programming. (yes i tried the online computer exchange and the experience was pathetic and the REMAN part BOGUS)
I know there are other engine sensors in the same 5v PCM circuit as the gov press sol, but REPLACE THEM ALL?!?! Are there better ways to test each individual sensor?

Clearly I don't own a DRB scan tool, but how can I know for certain the PCM is at fault? (Mopar reman dated 2006)
Should I buy a new TPS? Or have a shop sweep both TPS and Alternator with an oscilloscope?
I am proficient with my Fluke true RMS multimeter, and I do have the service manuals and haynes manual.
Any suggestions are greatly appreciated!
dealer don't know what they're talking about. if it's a drum issue it would be the inner lip seal in the direct drum, and if it is you would have a delayed or no 2-3 shift or a slipping or no reverse gear. I could lay my money down say it's either the ECM, the valvebody, the transmission sensors and solenoids, or the torque converter. it's pretty narrowed down since im not there to see the van with my own eyes.
Reply With Quote
Reply

Bookmarks

Tags
pcm, tps, transmission

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 06:04 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum