DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram 2002 to 2008 Dodge Ram Trucks > Electrical


Notices

Electrical 3rd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 03-25-2014, 10:14 PM
trevorw trevorw is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2014
Location: New Brunswick, Canada
Age: 38
Posts: 3
Gender: Male
Vehicle: 2008 dodge ram
Trim Level: sport
Color: black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
trevorw is on a distinguished road
Default Need electrical help...started with 4x4 problems.

I have an 08 ram 1500 hemi. Its been near -20 for past few weeks, except a few days ago, it got warm and slushy. some big puddles on the backroads i live on. That night my 4x4 started acting up. would go in and out at first, but 4wd light remained on dashboard. It turned cold again outside next day, light is still on, but wont go into 4wd. power windows quit for a short while, and voltage was reading high. This morning, the truck started for 3 seconds, shut off and will not start again. red lightning bolt is now on dash. no service engine light though. checked fuel pump, and all obvious connections, and fuses. error code p0882 . I'm just a backyard mechanic, and the nearest dealer is 100 miles away. I hate to dump cash for towing, and troubleshooting if there is a chance of fixing it myself, or at least knowing what my options are. Any advice would be greatly appreciated!!
Reply With Quote
Sponsored links
  #2  
Old 03-27-2014, 09:02 AM
easy e's Avatar
easy e easy e is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jan 2014
Location: New York
Posts: 99
Gender: Male
Vehicle: 2007
Trim Level: SLT
Color: Silver
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:21
easy e is on a distinguished road
Default

P0882 = TCM (transmission control module) voltage input low.

I've attached the diagnostic routine from the 2008 factory service manual.
Attached Files
File Type: pdf P0882.pdf (590.0 KB, 3 views)
__________________
2007 Hemi SLT 4x4 Quad Cab
260k miles and counting...

Last edited by easy e; 03-27-2014 at 10:07 AM.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 09:34 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum