DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 1ST Generation Dodge Ram 1993 & Older Dodge Ram Trucks > Electrical


Notices

Electrical 1st Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 01-01-2014, 07:30 PM
dschutz1979 dschutz1979 is offline
Dodge Ram Forum Newcomer
 
Join Date: May 2013
Location: georgia
Age: 35
Posts: 29
Gender: Male
Vehicle: 1987 dodge d150
Trim Level: le 150
Color: red and white
Engine: 1981-1987 318ci (5.2L) LA V8 140hp
Rep Power: 0
Rep:10
dschutz1979 is on a distinguished road
Default battery not charging

I have 14 volts coming out of alternator. But when I test the battery with the engine running it shows the battery to be almost dead. Any ideas? I'm starting to think something is wrong with the wire. Can I just run another wire from the alternator over to the battery?. The.engine just shut off and I finally found out its was the ground going from the engine to the firewall. And when I fixed it this problem come up. I'm getting desperate and fed up. The alternator, battery and voltAge regulator are all new.
Reply With Quote
Sponsored links
  #2  
Old 01-01-2014, 08:25 PM
hydrex's Avatar
hydrex hydrex is offline
Dodge Ram Forum Senior Member!
 
Join Date: Sep 2009
Location: Penobscot, Maine
Age: 63
Posts: 1,953
Gender: Male
Vehicle: 2005 QC 4X4 HEMI RAM
Trim Level: Thunder Road
Color: Mineral Grey
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 6
Rep:418
hydrex is just really nicehydrex is just really nicehydrex is just really nicehydrex is just really nicehydrex is just really nice
Default

Your truck is pretty old, the old wire cold be bad. Check it with a continuity tester/multi tool. If you get 0 ohms, it's shot. Replace it with a new wire of at least the same size wire. I'm a boatbuilder and we always use tinned copper marine grade wire.
__________________
Inertia Spartan Plus cam, Circle D 3,000 rpm stall converter,Sonnax line pressure booster, Vararam, JBA's with cut outs, Borla duals, Rancho 9000's,3:92's, extra rear leaf. 200,000 miles To Hell and back. 14.2/96 mph NEDW
Reply With Quote
  #3  
Old 01-01-2014, 10:11 PM
dbuzz77's Avatar
dbuzz77 dbuzz77 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Nov 2013
Location: Saskatchewan, Canada
Posts: 148
Gender: Male
Vehicle: 2009 Ram RCSB 4x4
Trim Level: Sport
Color: Stone White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 1
Rep:100
dbuzz77 will become famous soon enoughdbuzz77 will become famous soon enough
Default

check the battery voltage, truck not running. look for the same voltage on the alternator. if the battery voltage isn't at the alternator, it won't charge. follow the wires to the battery to find out if the alternator is connected properly.
__________________
2009 RCSB Sport, SC Cortex, K&N air box, all Amsoil fluids, Fan delete, Grounded TB, homemade catch can, homemade gps mount, Fastman TB, EZ down tailgate, Bully hitch step
Then God made a hemi, and knew that it was good.
Reply With Quote
  #4  
Old 01-02-2014, 10:35 AM
Warlock III's Avatar
Warlock III Warlock III is online now
Thinks sheep are stupid
 
Join Date: Aug 2010
Posts: 6,742
Gender: Male
Vehicle: 1995 Ram 1500
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 11
Rep:1734
Warlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant future
Send a message via AIM to Warlock III Send a message via Yahoo to Warlock III
Default

Check the fusable link coming off the battery (positive) along the driver's fender. Look for a wider section of the red wire to locate the fusable link. There should be 3 if I remember correctly. The fusable link is a lead-core section of wire that is designed to fail if there is an electrical failure. Such as losing the body-ground to the firewall.

Check the wires for breaks and replace it if you find one.
__________________
Rated "D" for disturbing. Some images and language may be disturbing for some members. Crude language, sarcasm and images throughout. Not intended for all viewers

DISCLAIMER
If you are offended easily don't click on my screen name
Reply With Quote
  #5  
Old 01-02-2014, 12:34 PM
DodgeAddict's Avatar
DodgeAddict DodgeAddict is offline
Dodge Ram Forum Junior Member
 
Join Date: Nov 2013
Location: KCMO
Age: 50
Posts: 36
Gender: Male
Vehicle: 9 trucks form 77-97
Trim Level: SS/T Adventurer SE
Engine: 1994-1997 360ci (5.9L) Magnum V8 230hp
Rep Power: 0
Rep:40
DodgeAddict is on a distinguished road
Default

Check the ground from the battery to the body If your blower motor is acting up (dragging) It will blow 2 possible fuse links causing a no charge condition
__________________
My wife says I'm addicted to Dodge I have the CCDD chromosome in my DNA It's genetic!
Reply With Quote
  #6  
Old 02-26-2014, 01:30 PM
RYAN1991 RYAN1991 is offline
Dodge Ram Forum Newcomer
 
Join Date: Feb 2014
Location: Canada
Posts: 3
Gender: Male
Vehicle: 2005 Dodge Ram 1500
Trim Level: SLT
Color: Black
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
RYAN1991 is on a distinguished road
Default

Quote:
Originally Posted by DodgeAddict View Post
Check the ground from the battery to the body If your blower motor is acting up (dragging) It will blow 2 possible fuse links causing a no charge condition
I have a 2005 Ram with similar issues, and my blower motor will only run on the highest setting. Could this be the same issue?
Reply With Quote
  #7  
Old 02-26-2014, 01:38 PM
Warlock III's Avatar
Warlock III Warlock III is online now
Thinks sheep are stupid
 
Join Date: Aug 2010
Posts: 6,742
Gender: Male
Vehicle: 1995 Ram 1500
Engine: 1994-2001 318ci (5.2L) Magnum V8 220hp
Rep Power: 11
Rep:1734
Warlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant futureWarlock III has a brilliant future
Send a message via AIM to Warlock III Send a message via Yahoo to Warlock III
Default

Quote:
Originally Posted by RYAN1991 View Post
I have a 2005 Ram with similar issues, and my blower motor will only run on the highest setting. Could this be the same issue?
Yours is an '05 so there's a completely different system. In my experience, the '05 is usually the blower motor itself to be at fault.

Since your's is a 3rd Gen it may be best to start a new thread or add to an existing thread under the 3rd Gen section, heating and cooling if a search doesn't return any helpful results.

I did a search for "05 blower motor only works on high" and this is what came up:http://www.ramforumz.com/search.php?searchid=3641492

There should also be a small thermal relay under the passenger's side of the dash that may be faulty.
__________________
Rated "D" for disturbing. Some images and language may be disturbing for some members. Crude language, sarcasm and images throughout. Not intended for all viewers

DISCLAIMER
If you are offended easily don't click on my screen name

Last edited by Warlock III; 02-26-2014 at 01:43 PM.
Reply With Quote
  #8  
Old 03-12-2014, 10:52 PM
vdubs63's Avatar
vdubs63 vdubs63 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2014
Location: Sacramento, CA
Age: 21
Posts: 5
Gender: Male
Vehicle: 2001 Dodge Ram 1500
Trim Level: SLT
Color: White/Grey
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
vdubs63 is on a distinguished road
Default

I have a 2001 Ram 1500 and it's doing a similar thing. I had a bad alternator so I replaced it with a new one from Auto Zone. I thought everything was fine but about 5 minutes after driving it the battery charge level dropped to zero and the Check Gauge light came on. I thought maybe it was a loose wire or something that caused it to do that but a little while later my dash cluster just dropped to zero on my way home. I got home and pulled out the voltage meter and the battery wasnt even charging. I pulled the positive lead and it just killed the motor. My alternator fuse is in good shape and I have looked at all my grounds and they are all in good shape, not rusted or corroded at all. I'm kind of confused at why this is happening. I have seen on some other posts where people said their blower motors wouldnt work or would only blow on high, and I do not have that problem. Why isn't it charging?
Reply With Quote
  #9  
Old 03-12-2014, 11:35 PM
namretsud's Avatar
namretsud namretsud is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2012
Location: SW Ontario
Age: 59
Posts: 462
Gender: Male
Vehicle: 2007 1500 Mega Cab 4X4 3.73
Trim Level: SLT
Color: Inferno Red
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 3
Rep:185
namretsud has a spectacular aura aboutnamretsud has a spectacular aura about
Default

Quote:
Originally Posted by vdubs63 View Post
I have a 2001 Ram 1500 and it's doing a similar thing. I had a bad alternator so I replaced it with a new one from Auto Zone. I thought everything was fine but about 5 minutes after driving it the battery charge level dropped to zero and the Check Gauge light came on. I thought maybe it was a loose wire or something that caused it to do that but a little while later my dash cluster just dropped to zero on my way home. I got home and pulled out the voltage meter and the battery wasnt even charging. I pulled the positive lead and it just killed the motor. My alternator fuse is in good shape and I have looked at all my grounds and they are all in good shape, not rusted or corroded at all. I'm kind of confused at why this is happening. I have seen on some other posts where people said their blower motors wouldnt work or would only blow on high, and I do not have that problem. Why isn't it charging?
How old is your battery? Have you had your battery load tested? This winter has been very hard on batteries all over. I don't have a lot of faith in the new cheap out style of battery post connecters that are used on todays vehicles. I have changed my connecters to marine grade battery connecters and I have a lot more faith in having a good battery connection.
Reply With Quote
  #10  
Old 03-13-2014, 08:52 PM
vdubs63's Avatar
vdubs63 vdubs63 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2014
Location: Sacramento, CA
Age: 21
Posts: 5
Gender: Male
Vehicle: 2001 Dodge Ram 1500
Trim Level: SLT
Color: White/Grey
Engine: 1998-2001 360ci (5.9L) Magnum V8 245hp(standard), 250hp(Sport package)
Rep Power: 0
Rep:10
vdubs63 is on a distinguished road
Default

Today I went and exchanged my alternator for another one and I also bought a new battery because my old one was shot. My battery reads 12.40 just sitting there and it reads 11.90 while running. I went to take it around the block right after I put in the new stuff and the Check Gauge light came back on and the Charge Gauge went to the red line. I checked my cables and fuses and they are all ok. I'm have run out of ideas of what could potentially be wrong.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 07:52 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum