DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - Help Zone - Dodge Ram Problems, Complaints, & Solutions - Maintenance & Re > 3RD Generation Dodge Ram – 2002 to 2008 Dodge Ram Trucks > Electrical


Notices

Electrical 3rd Gen Dodge Ram Electrical Problems and Questions.


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 01-12-2014, 07:02 PM
FarmTruck FarmTruck is offline
Dodge Ram Forum Junior Member
 
Join Date: Sep 2013
Location: Canada
Posts: 42
Gender: Male
Vehicle: 2003 1500 4x4 QuadCab ShortBox
Trim Level: Laramie
Color: Blue
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
FarmTruck is on a distinguished road
Default ’03 killing batteries

I keep killing the battery in the truck if I don’t drive it every day or if it gets cold out and I am wondering if there are and common causes or recommended starting points for troubleshooting. I pulled out all the fuses and relays under hood and I see a 0.02 amp draw when I connect an amp meter in series with the battery even after the vehicle is off for 15 minutes.
Reply With Quote
Sponsored links
  #2  
Old 01-13-2014, 02:30 PM
RogerRamJet's Avatar
RogerRamJet RogerRamJet is offline
God Bless Texas!




 
Join Date: May 2013
Location: Mansfield, TX
Age: 49
Posts: 11,024
Gender: Male
Vehicle: 2005 Ram 1500
Trim Level: Lonestar QC
Color: White
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 12
Rep:2929
RogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond reputeRogerRamJet has a reputation beyond repute
Default

.02 is normal. If you don't have a draw somewhere else greater that .05, I would look at the getting the battery checked to make sure it's still holding it's charge.
__________________
Life is hard... It's harder if you're stupid!
Today is a good day to be a RAM owner!
Reply With Quote
  #3  
Old 01-14-2014, 11:01 PM
Simple guy Simple guy is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jun 2013
Location: Pottstown, Pa
Age: 27
Posts: 247
Gender: Male
Vehicle: 2003 Ram 1500
Trim Level: SLT QC 4x4
Color: Mineral grey
Engine: 2002-2003 360ci (5.9L) Magnum V8 245hp 335lb/ft
Rep Power: 2
Rep:109
Simple guy will become famous soon enoughSimple guy will become famous soon enough
Default

Get it load tested, Mine is doing the same thing. lose my radio presets every time. i'm just trying hold out as long as i can to buy a new battery.
__________________
Reply With Quote
  #4  
Old 01-15-2014, 11:57 PM
FarmTruck FarmTruck is offline
Dodge Ram Forum Junior Member
 
Join Date: Sep 2013
Location: Canada
Posts: 42
Gender: Male
Vehicle: 2003 1500 4x4 QuadCab ShortBox
Trim Level: Laramie
Color: Blue
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
FarmTruck is on a distinguished road
Default

If I'm getting the typical draw I suspect I have gotten a dud battery. Thank you guys.

Previous owner put a new one in the week before I got it (summer), but it is a low end battery. He messed up the battery retainer when he did it so it seems I'll need drill out the bolt holding it in to get it out, that's why I have not taken it in to get tested. Since I've had the truck I've been using a charger and pulling the negative when it sits.

I'm lucky, I don't loose my presets even when I pull the neg terminal.
Reply With Quote
  #5  
Old 01-25-2014, 06:58 PM
AFMEDIC's Avatar
AFMEDIC AFMEDIC is offline
Dodge Ram Forum Senior Member!

 
Join Date: Aug 2012
Location: Kentucky
Posts: 161
Gender: Male
Vehicle: 2002 Dodge Ram
Trim Level: SLT
Color: Maroon
Engine: 2002-2007 287ci (4.7L) PowerTech V8 235hp 295lb/ft
Rep Power: 0
Rep:18
AFMEDIC is on a distinguished road
Default

Autozone can load test it in the vehicle for free if you stop by there. My radio presets stay as well. My truck kills all of the power if I leave something on and everything comes back when I put the key in. I give my wife crap all the time because my dodge won't let me kill the battery by leaving lights on but her ford's battery dies all the time when she forgets lights!
__________________
If Guns kill people, then pencils misspell words and spoons made Rosie O'Donnell fat...
Reply With Quote
  #6  
Old 02-25-2014, 12:54 PM
FarmTruck FarmTruck is offline
Dodge Ram Forum Junior Member
 
Join Date: Sep 2013
Location: Canada
Posts: 42
Gender: Male
Vehicle: 2003 1500 4x4 QuadCab ShortBox
Trim Level: Laramie
Color: Blue
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
FarmTruck is on a distinguished road
Default

During the last warm spell I pulled the old battery and dropped in a new AGM unit and a battery disconnect. The old battery tested bad when I took it in. It had been drained so many times I saw it as inconclusive so I've been disconnecting the battery when the vehicle is parked and have not had any problems for the last few weeks.

It was supposed to warm up this week so I left the battery connected after I parked the truck Friday. Last night (Monday) I tried to fire it up to pull a neighbour out of a ditch. It was -20c and I only got a half crank at full speed then a couple of slow cranks. Popped it on the charger and it showed ~25% charge.

So I seem to still have a draw issue and I may need to replace or upgrade a few cables. I'll probably wait on cable upgrades until after I get the motor rebuilt or replaced.
Reply With Quote
  #7  
Old 02-25-2014, 01:25 PM
Arth's Avatar
Arth Arth is offline
Dodge Ram Forum Member


 
Join Date: Jan 2012
Location: North Carolina
Posts: 3,049
Gender: Male
Vehicle: 2013 Ram 1500 Crew Cab 4x4
Trim Level: Laramie
Color: Mineral Gray Metallic
Engine: 2013-20?? 345ci (5.7L) Hemi V8 395hp 410lb/ft
Rep Power: 8
Rep:2008
Arth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond reputeArth has a reputation beyond repute
Default

You may have a draw or is your alternator actually charging the battery?

To me is almost sounds like your charging system isn't charging the battery at all.

I remember when the alternator in my suburban was going out. Made it to autozone and had the battery tested it only showed like 55% charge or something. Cranked the truck over and the alternator failed the regulator and diode test.

Replaced the alternator and no issues after that!
__________________

Chrome... in moderation.
Reply With Quote
  #8  
Old 02-25-2014, 09:07 PM
FarmTruck FarmTruck is offline
Dodge Ram Forum Junior Member
 
Join Date: Sep 2013
Location: Canada
Posts: 42
Gender: Male
Vehicle: 2003 1500 4x4 QuadCab ShortBox
Trim Level: Laramie
Color: Blue
Engine: 2003-2008 345ci (5.7L) Hemi V8 345hp 375lb/ft
Rep Power: 0
Rep:10
FarmTruck is on a distinguished road
Default

Quote:
Originally Posted by Arth View Post
You may have a draw or is your alternator actually charging the battery?

To me is almost sounds like your charging system isn't charging the battery at all.
I've been running the battery for some time and had over 50 starts, so there must be some charging. It had tested OK in the fall, but I guess could test again.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 10:28 AM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum