DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > 2013 Dodge Ram Forum


Notices

2013 Dodge Ram Forum For specific discussion of the 2013 Dodge Ram!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
Bayou Goat Mounts

Reply
 
Thread Tools
  #61  
Old 07-08-2013, 12:08 PM
toober's Avatar
toober toober is offline
Dodge Ram Forum Senior Member!
 
Join Date: Jul 2013
Location: South Texas
Age: 42
Posts: 173
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Tradesman
Engine: 2013-20?? 220ci (3.6L) Pentastar 305hp 269lb/ft
Rep Power: 0
Rep:26
toober is on a distinguished road
Default

Quote:
Originally Posted by mcritchie View Post
Hey guys and gals,

I have a 2013 ram sport with the 8.4an system. I just noticed that when i exit the truck and lock the doors the radio and the instrument cluster lights won't go out. I am aware that there is an "engine off" section among the setting where you can change the time before the headlights and radio turn off after the engine is shut down. My settings are at 45 seconds for the radio and 30 for the headlights (or vise versa). Anyway, have any of you guys had this problem? any ideas what the problem could be? Also, is there battery rundown protection on the truck?
Quote:
Originally Posted by dubstalon View Post
After 16 days in the shop, I finally have my truck back. The dealer replaced the gauge cluster on Wednesday and everything seems to be working so far. So it has a new BCM, radio and gauge cluster now.
So have you found the problem to be fixed now? Were they able to pinpoint which item was at fault of the three (bcm, gauge cluster, radio)? I'm taking my truck in soon for the same problem.
__________________
.
Reply With Quote
  #62  
Old 08-14-2013, 12:11 AM
dubstalon dubstalon is offline
Dodge Ram Forum Newcomer
 
Join Date: Apr 2013
Location: Broken Arrow OK
Age: 38
Posts: 8
Gender: Male
Vehicle: 2013 RAM 1500
Trim Level: Express
Color: Mineral gray
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
dubstalon is on a distinguished road
Default

Yes my radio problem is fixed. After they installed a new gauge cluster the radio issue is finally fixed. Now if they could get the thing to stop shaking between 65-75 mph.
Reply With Quote
  #63  
Old 10-14-2013, 12:22 PM
metis motors metis motors is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2013
Location: Alberta
Age: 29
Posts: 7
Gender: Male
Vehicle: 2013 Ram 1500 SLT
Trim Level: SLT
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
metis motors is on a distinguished road
Default

Well yesterday was the day that my radio and dash lights would not go off. so we shall see what my dealership has to say about this tomorrow cause in Canada today is a holiday. also my key has not wanted to come out sometimes and my transmission has stayed in 7th gear for no reason. very interesting. at least I will not be talking to the dealership uninformed. also I unhooked the battery last night when I got home cause the lights were on all day. so hopefully dodge has a cure for these issues.
Reply With Quote
  #64  
Old 10-15-2013, 04:43 PM
biesek2006 biesek2006 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: Baraboo, Wisconsin
Posts: 12
Gender: Male
Vehicle: 2013 Ram
Trim Level: Express
Color: Maximum Steel
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
biesek2006 is on a distinguished road
Default

I haven't had any trouble since they updated my Body Control Module I have an Express with the basic radio
Reply With Quote
  #65  
Old 10-25-2013, 11:47 PM
metis motors metis motors is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2013
Location: Alberta
Age: 29
Posts: 7
Gender: Male
Vehicle: 2013 Ram 1500 SLT
Trim Level: SLT
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
metis motors is on a distinguished road
Default

Well I took my truck to dodge today for that dash radio problem. and they did an update that failed the second time I shut the truck off so I took it back since I had not left the city yet and they found a brand new update out just this week and apparently my truck was the first one to get it. and so far so good. but they said that when or if this fails... out with the radio and dash. and by the way I told them what I had learned on this site and they kinda played innocent , but all in all so far so good. I should have asked them about that bad smell in the cab.
Reply With Quote
  #66  
Old 11-23-2013, 12:03 AM
White1 White1 is offline
Dodge Ram Forum Newcomer
 
Join Date: Aug 2013
Location: Canada
Posts: 27
Gender: Male
Vehicle: 2013 Dodge Ram
Trim Level: Longhorn
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
White1 is on a distinguished road
Default Dash lights

This happened to me a few days back. Cluster lights stayed on and the battery went dead... At least nothing inside the truck would power up. I didn't check the voltage, so I am not sure if it was dead or the battery protection feature was activated. I charged the battery as the hood light was very dim, and I still could not get any power inside the truck at all (hood light was the only thing that had power). Disconnected the battery neg terminal to reset. When I reconnected the battery the alarm went off till I hit the unlock button on the key fob. Anyway, all ok again, for now at least, but a bit disappointing for a Longhorn with 4000 kms on it. Hopefully just a glitch. I added wrench for the battery terminal to the emergency kit and a note to self to check the cluster lights when I lock it up..
Reply With Quote
  #67  
Old 11-23-2013, 12:37 AM
Explorer Rob's Avatar
Explorer Rob Explorer Rob is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2012
Location: Mesa, AZ
Age: 48
Posts: 1,186
Gender: Male
Vehicle: 2013 Ram 1500 4x4
Trim Level: Laramie Longhorn
Color: Black Gold / White Gold
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 2
Rep:264
Explorer Rob is a jewel in the roughExplorer Rob is a jewel in the roughExplorer Rob is a jewel in the rough
Default

What software version is your radio at? The earlier versions had that issue. If you don't have the latest version, try going to the Uconnect website to download the latest version. If you are uncomfortable doing it, your dealer will do it under warranty.
Reply With Quote
  #68  
Old 11-26-2013, 01:14 AM
boomer135 boomer135 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Dec 2012
Location: USA
Posts: 177
Gender: Male
Vehicle: 2013 Ram
Trim Level: 4X4 CC Sport
Color: Mineral Grey
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:39
boomer135 is on a distinguished road
Default

I am another one bit by this bug, just 3 days ago battery was dead. I charged the battery and dead again in the morning. Noticed on the 3rd recharge the Evic would stay illuminated, not shutting off.

I disconnected the ground so the battery wouldn't drain, and took it to the dealer this morning.

They preformed all the software updates, and the recalls. EVIC now shuts down and they also tested for any battery drain, when vehicle is off. So far so good… Problem fixed for now.
__________________
MODS: PE Full Metal Jackrabbit, BT Catch can, Magnaflow 18", Vararam, Bullydog Hemi Tuner, Zone 1.5 BL, Bilstein 5100's @2.8, TG 1.5 rear coil Spacers, Fuel 20x10 -12OS, Toyo OC MT 315/60R20, Painted BW Pocket Flares http://www.ramforumz.com/showthread....88#post1344588
Reply With Quote
  #69  
Old 12-06-2013, 10:54 AM
metis motors metis motors is offline
Dodge Ram Forum Newcomer
 
Join Date: Oct 2013
Location: Alberta
Age: 29
Posts: 7
Gender: Male
Vehicle: 2013 Ram 1500 SLT
Trim Level: SLT
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
metis motors is on a distinguished road
Default

Have any of you noticed that when you got your radio fixed that the volume was reduced? cause when I bought my truck I was looking at a 300 first and that car was beautiful. and one of the reasons that I chose the truck was the stereo, the truck would do at 22 what the car would do wide open. now I notice that I have to have the stereo at 29 and the base is no longer there, It is that noticeable ! Before the stereo was thick and rich now its weak and thin. I HATE IT!
Reply With Quote
  #70  
Old 01-12-2014, 12:00 PM
Razzaa Razzaa is offline
Dodge Ram Forum Newcomer
 
Join Date: Jul 2013
Age: 35
Posts: 10
Gender: Male
Vehicle: 2013 1500 Sport
Trim Level: Sport
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Razzaa is on a distinguished road
Default

Currently having this issue. Last time i took it in they updated the software. The update fixed it for 2 weeks. Now it is sitting outside and wont start. Getting annoying to say the least.
Reply With Quote
Reply

Bookmarks

Tags
2013, battery, lights, ram, sport

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 05:21 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum