DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

Go Back   DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum > Dodge Ram Forum - General Discussion > 2013 Dodge Ram Forum


Notices

2013 Dodge Ram Forum For specific discussion of the 2013 Dodge Ram!


Latest Vendor News
AutoAnything
Addictive Desert Designs!
United Radio
Bayou Goat Mounts

Reply
 
Thread Tools
  #1  
Old 12-01-2013, 10:43 AM
Firemedic10584 Firemedic10584 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Nov 2013
Location: Central FL
Posts: 718
Gender: Male
Vehicle: 2013 Ram 1500 Sport
Trim Level: Sport
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 1
Rep:113
Firemedic10584 will become famous soon enoughFiremedic10584 will become famous soon enough
Default a WTF moment! ideas?

Taking a short 30 minute drive this morning. Had the cruise control set at 55 and the whole instrument cluster and screen went out. It came right back on and did it again a minute later. I pulled over and shut the truck off and it hasn't done it again. Any ideas?
Reply With Quote
Sponsored links
  #2  
Old 12-01-2013, 11:51 AM
jaray jaray is offline
Dodge Ram Forum Senior Member!
 
Join Date: Mar 2012
Location: Ontario, Canada
Posts: 110
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Sport Crew
Color: Silver
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 3
Rep:197
jaray has a spectacular aura aboutjaray has a spectacular aura about
Default

That's a problem just waiting to show its face again in some other shape or form. I'd be taking it to the dealer to at least make sure it's noted.
Probably very tough for them to troubleshoot that until they see it happen, especially if Its just a one time thing which doesn't throw a trouble code.
__________________
Gibson Cat-back exhaust w/black tips, S&B CAI, MGP caliper covers, Recon LED 3rd brake light, Bilstein 5100's, Daystar 1" rear coil spacers, Weathertech floor liners, Westin Ultimate series bull bar, Dee Zee Tailgate Assist, Mopar T- Handle, Kicker speaker upgrade
Reply With Quote
  #3  
Old 12-01-2013, 11:54 AM
spoiler's Avatar
spoiler spoiler is online now
Dodge Ram Forum Member
 
Join Date: Feb 2013
Location: California
Posts: 765
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Laramie
Color: Black
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 2
Rep:364
spoiler is just really nicespoiler is just really nicespoiler is just really nicespoiler is just really nice
Default

I don't know the cause but it happened to me once as well. My fully loaded 2013 started up as usual two weeks after I bought it. Normal except the screens were blank. I paused a moment. wondered, put in in reverse, backed out and headed to work totally stumped. I even pulled over and restarted the truck. Still blank. Drove 20 miles to work. Restarted it up and all was perfect. I worried about it for a few days and kept waiting for it to reoccur so I could take it in….. 10,500 miles later it has never happen again.
I believe it is called "Ghost in the Machine"
I hope yours is that simple.
__________________
Vararam Air Grabber, Vararam Power Chamber, 87mm TB, Diablo Tuner with HemiFever 91 tune, Magnaflow Muffler, Boss 338 22 x 9.5, Toyo Proxy 305 45 R22, GroundForce 2/3
Reply With Quote
  #4  
Old 12-01-2013, 12:47 PM
Darkwind72's Avatar
Darkwind72 Darkwind72 is offline
Dodge Ram Forum Newcomer
 
Join Date: Mar 2010
Location: Drayton Valley, AB
Age: 42
Posts: 24
Gender: Male
Vehicle: 2013 Dodge Ram 1500 Sport CC
Trim Level: Sport
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:10
Darkwind72 is on a distinguished road
Default

Quote:
Originally Posted by Firemedic10584 View Post
Taking a short 30 minute drive this morning. Had the cruise control set at 55 and the whole instrument cluster and screen went out. It came right back on and did it again a minute later. I pulled over and shut the truck off and it hasn't done it again. Any ideas?
I had the same thing happen to me too, about three weeks ago. My cluster, radio, everything went out, including my power steering.

After going to the dealership (twice), the alternator was overcharging everything. The alternator had to be replaced, and I had several computer flashes done to my truck as well.

I'm not sure if you've got the same problem as I did, but it may be something that the dealership might want to check out.
__________________
Dave
Current Vehicle: 2013 Dodge Ram 1500 Sport CC 4X4
Reply With Quote
  #5  
Old 12-01-2013, 01:14 PM
Firemedic10584 Firemedic10584 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Nov 2013
Location: Central FL
Posts: 718
Gender: Male
Vehicle: 2013 Ram 1500 Sport
Trim Level: Sport
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 1
Rep:113
Firemedic10584 will become famous soon enoughFiremedic10584 will become famous soon enough
Default

OK thanks everyone. I'll swing by the dealer tomorrow and at least inform them of it. Hopefully it was just a fluke and won't happen again!
Reply With Quote
  #6  
Old 12-01-2013, 01:46 PM
GTyankee's Avatar
GTyankee GTyankee is offline
Dodge Ram Forum Member

 
Join Date: Dec 2009
Location: San Diego East County, Ca
Posts: 18,559
Gender: Male
Vehicle: 2009 Dodge Ram 1500 2X4
Trim Level: quad cab SLT
Color: sunburst orange pearl
Rep Power: 19
Rep:2608
GTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond reputeGTyankee has a reputation beyond repute
Default

If you think about it, what happens when you shut off the key
you are resetting something within the electronics system

My '09 EVIC goes blank from time to time, what i do is tap the left upper or lower EVIC button on the steering wheel, it has lit up every time that i have done that.
I have 99,600+ miles on it
__________________
Ram 1500 SLT Quad cab, 5.7 HEMI(R) MDS VCT, 5 speed auto 545RFE, 3.55 differential gears, 18" Magnaflow muffler, EGR bug deflector, Bushwacker fender flares, customized Nfab nerf bars, CB radio, Autonet wi-fi router, custom soft tonneau cover, Line_X bedliner, DEBO Step, build date 10/15/08 a Wednesday built vehicle
Reply With Quote
  #7  
Old 12-01-2013, 02:10 PM
Firemedic10584 Firemedic10584 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Nov 2013
Location: Central FL
Posts: 718
Gender: Male
Vehicle: 2013 Ram 1500 Sport
Trim Level: Sport
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 1
Rep:113
Firemedic10584 will become famous soon enoughFiremedic10584 will become famous soon enough
Default

Quote:
Originally Posted by GTyankee View Post
If you think about it, what happens when you shut off the key
you are resetting something within the electronics system

My '09 EVIC goes blank from time to time, what i do is tap the left upper or lower EVIC button on the steering wheel, it has lit up every time that i have done that.
I have 99,600+ miles on it
That is what it simulated. All the gauges and screen went to the "off" position then came right back on.
Reply With Quote
  #8  
Old 12-01-2013, 02:12 PM
Ramzaq Ramzaq is offline
Dodge Ram Forum Senior Member!
 
Join Date: Aug 2010
Location: Northern California
Posts: 515
Gender: Male
Vehicle: 2009 Ram CC 4X4
Trim Level: SLT, Big Horn
Color: Black Pearl coat
Engine: 2009-2010 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 5
Rep:229
Ramzaq has a spectacular aura aboutRamzaq has a spectacular aura aboutRamzaq has a spectacular aura about
Default

Had a similar issue years ago with a Caravan, '97. I know it is not a Ram. They had some issues with the displays going dead and it was poor solder connections on the display. Hit the connections with a solder iron and haven't had a problem since.

Maybe similar. When you get some time take it to the dealer and let them know about it.

I have also read on some forums when turning down the brightness on the display it starts blinking or pulsing. This could be an indication of poor clocking (frequency) for the led's a lcd's. It is possible this may tie in with your problem.
Reply With Quote
  #9  
Old 12-01-2013, 02:15 PM
edge35's Avatar
edge35 edge35 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Feb 2013
Location: Houston, Texas
Posts: 452
Gender: Male
Vehicle: 2013 Ram 1500
Trim Level: Laramie Longhorn 4x4
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 0
Rep:70
edge35 will become famous soon enough
Default

This issue started occurring to me after the last Uconnect firmware update. Never did it before that. I'd say I' hope the next firmware update fixes it but who knows what new issues it will introduce...
__________________
2013 Laramie Longhorn 4x4
6 speed (although the 65RFE is really a 5 speed), 3.55, air suspension, anti-spin, 20" Goodyear Wrangler SRA tires (aka crap), sunroof, Bakflip Fibermax & BakBox, bed extender, 8.4AN, black/cattle tan interior
Reply With Quote
  #10  
Old 12-01-2013, 02:50 PM
Firemedic10584 Firemedic10584 is offline
Dodge Ram Forum Senior Member!
 
Join Date: Nov 2013
Location: Central FL
Posts: 718
Gender: Male
Vehicle: 2013 Ram 1500 Sport
Trim Level: Sport
Color: White
Engine: 2009-20?? 345ci (5.7L) Hemi V8 390hp 407lb/ft
Rep Power: 1
Rep:113
Firemedic10584 will become famous soon enoughFiremedic10584 will become famous soon enough
Default

I think the issue I had was slightly different than what you all are mentioning. All my gauges actually went as if I turned the truck off when I did not obviously and the digital speedometer went off also. Then it all came back on and then happened again. Regardless, I'll be making a trip to the dealer in the morning and hope it's nothing but just a ghost in the system.
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Advertisement






All times are GMT -4. The time now is 11:31 PM.


= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors


=Gigathreads Network=
CLUBS MOPAR NATION DSM GPMM MAMM JAM
DIESEL Diesel Forum      
CHEVY Chevy Camaro Forum Chevy Volt Forum    
CHRYSLER Chrysler 300C Forum      
DODGE Dodge Avenger Forum Dodge Caliber Forum Dodge Challenger Forum Dodge Charger Forum
  Dodge Circuit Forum Dodge Hornet Forum Dodge Magnum Forum Dodge Nitro Forum
  Dodge Ram Forum Dodge Dakota Forum Dodge Durango Forum Dodge Dart Forum
FORD Ford Raptor Forum Ford F150 Forum Ford F100 Forum  
JEEP Jeep Forum      
PONTIAC Pontiac G8 Forum      
SRT SRT Viper Forum SRT Cuda Forum