View Single Post
  #17  
Old 11-01-2013, 10:28 PM
dvarn's Avatar
dvarn dvarn is offline
Dodge Ram Forum Member

 
Join Date: Jul 2013
Location: Cape May Co, NJ
Posts: 280
Gender: Male
Vehicle: 2009 Dodge Ram 4x4 QC
Trim Level: Laramie
Color: Stone White
Rep Power: 2
Rep:181
dvarn has a spectacular aura aboutdvarn has a spectacular aura about
Default

Quote:
Originally Posted by KnuckleHead View Post
Where did you get a Phillips set? I love HIDs but I have not had the best luck with them. I have had maybe a dozen kits over the years between my vehicles and friends vehicles (that I installed) and some work great (had some in my Honda that worked great for 4 years with no issues at all) but then some work for a month and then bulbs don't light up, ballasts go out, etc. Most of my kits were from DDM.

So, if I could buy a good NAME BRAND quality kit, I would be more likely to put one in my Laramie. I have searched high and low (good pun there) for a name brand (read non-Chinese) kit with no luck.
I don't remember the website I got them from, but I did a quick search and this is what mine look like. I did have to drill a hole in the rear of the headlights to get the bulb and wiring in there, but so far no issues with that. The wiring harness is at the bottom of the page. Looks like they're less expensive now than when I got mine.

And, most importantly, do NOT touch the bulb or let it get any kind of residue on it while you're installing them. That's a HID killer for sure

http://www.philipsxenon.com/dodge-c-...ips-hid-p-1247

Last edited by dvarn; 11-01-2013 at 10:30 PM.
Reply With Quote