DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum

DODGE RAM FORUM - Ram Forums and Owners Club! - Dodge Truck Forum (http://www.ramforumz.com/index.php)
-   2011 Dodge Ram Forum (http://www.ramforumz.com/forumdisplay.php?f=117)
-   -   First Mod Done! K&N CAI (http://www.ramforumz.com/showthread.php?t=79102)

Lothario80 04-04-2011 01:15 AM

First Mod Done! K&N CAI
 
2 Attachment(s)
Hey Everyone,

Just finished installing my K&N CAI a couple days back and so far couldn't be happier with the MUCH quicker throttle response and the deep throaty groan on heavy acceleration!

I do have a question for all those who have a K&N CAI though. Popped the hood today and noticed that I am getting some water spots and splashing all the way up inside the heat guard and a couple on the filter. I did notice there is a pretty good gap between the bottom edge of the heat shield and the fender yet all my edges are snug up as they should be.

Is this normal for this type of CAI?

Thanks for the help and here are some Lo-Rez pictures :)

jc4041 04-04-2011 04:17 AM

haven't looked at mine since I put it in....might do that when I get off of work in the morning...but I did notice the gap as well, I have to do some playing around and figure something out :thk:

black 11 04-04-2011 09:05 AM

Has it done anything as far as MPG or just more responsive and sound what was the price on that k+n

RockyRam 04-04-2011 09:09 AM

Nice install!!!!

bigrubbers4x4 04-04-2011 10:30 AM

very nice! i will be doing this down the road. i have done this same type of system on all my prior vehicles, some water getting splashed up on it seems normal to me. my dads got the K&N FNPK system on his 2006 ram and an Aero exhaust and boy does it run way better than it did stock.

Lothario80 04-04-2011 10:48 PM

Quote:

Originally Posted by black 11 (Post 491762)
Has it done anything as far as MPG or just more responsive and sound what was the price on that k+n


Really hard to judge.... I bought the truck new at the end of Feb in the middle of a horrible cold snap and roads covered in ice (120 days of snow on the ground this year). Up until about a week ago, when I installed the CAI we've had some great weather and as such I am doing a lot less idling. I was pulling 21L/100km (11.2MPG Avg) and now around 19L/100km (12.4MPG Avg). I do a really slow stop and go commute from home to downtown hitting almost every light. (about 15km or 9.3 Miles).

Now the one thing I will say is that I am driving it a lot harder with that sweet sound. So if I have actully gained anything with my newly found lead foot - I am happy :)


I picked it up from one of my fleet Vendors for $266CDN + Taxes

Loth

Lothario80 04-04-2011 10:51 PM

Quote:

Originally Posted by RockyRam (Post 491767)
Nice install!!!!

Thanks!

Joining the Mineral Grey Group!

Lothario80 04-04-2011 10:56 PM

Quote:

Originally Posted by jc4041 (Post 491688)
haven't looked at mine since I put it in....might do that when I get off of work in the morning...but I did notice the gap as well, I have to do some playing around and figure something out :thk:

Let me know what you find! I'm tempted to build a custom splash guard to protect the CAI.

Loth


All times are GMT -4. The time now is 07:16 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
vB.Sponsors
= Copyright RamForumZ.com a Gigathreads.com Network Site =Ad Management by RedTyger